Password Protect XP File Sharing

 Home

News

Forums

Hardware

CPUs

Motherboards

Video

Guides

CPU Prices

RAM Prices


Sharky Extreme : Forums:


Results 1 to 6 of 6

Thread: Password Protect XP File Sharing

  1. #1
    Catfish
    Join Date
    Oct 2001
    Location
    Pa
    Posts
    132

    Post Password Protect XP File Sharing

    I just got XP and I cannot figure out how to password protect a drive/folder shared on the network. I am trying to share my C: drive, although I do not want everyone to be able to access it. In win2k it would use the users password, but XP doesn't seem to do this. Anyone know how to password network shares on XP? Let me be a little more specific, because I just noticed something. When I enabled "remote access to this computer" in Network sharing and security section under the sharing tab, it enables the guest account, which is usually disabled. It then uses this account to share the files. I want to use MY account to share the files, NOT the guest account. This was possible to do in Win2K and I surely hope its possible in XP.

    ------------------
    -Xero

    [This message has been edited by Xero (edited November 01, 2001).]

  2. #2
    Reef Shark Invicta's Avatar
    Join Date
    Oct 2001
    Location
    Visalia, CA
    Posts
    478

    Post

    Have you tried the included help program in XP?
    A+, Network+, Security+, Project+, CCNA, MCSA:Security, MCSE:Security, VMware Certified Professional and I forget the rest - Certified -woohoo!
    Working towards MBA FTW!

  3. #3
    Catfish
    Join Date
    Oct 2001
    Location
    Pa
    Posts
    132

    Post

    I searched the thing in and out, been there done that. So far I have found absolutely no help with this issue, I even saw it go unanswerd on another forum posted by someone else

    ------------------
    -Xero

  4. #4
    Catfish
    Join Date
    Oct 2001
    Location
    Pa
    Posts
    132

    Post

    Wait, I just got it, alright, hopefully this will be useful to someone else. It was in the help file but wasn't very specific. Ok in the local policies under Security Options theres an option called "Network access: Sharing and security model for local accounts" this by default is set to guest, its much more secure set to classic - local users...Oh yes, one more thing, by doing this, the sharing tab now looks like Win2ks! Yay! well, this is definitely interesting behavior, I don't know why microsoft chose for xp to act that way....guest account=bad

    ------------------
    -Xero

    [This message has been edited by Xero (edited November 01, 2001).]

  5. #5
    Great White Shark
    Join Date
    Nov 2000
    Posts
    21,595

    Post

    Both of my versions, Pro and Server, have a permissions button for setting up security on shares. I suspect that you have the Home version of XP with fewer security features.

    ------------------
    Never forget 11 September 2001. May the victims forever rest in peace.

  6. #6
    Catfish
    Join Date
    Oct 2001
    Location
    Pa
    Posts
    132

    Post

    No, I am using pro, I had to set the local policies to use "Classic" instead of "guest" in return using guest removes the permission button and enables the new "XP" style sharing which pretty much sucks. I suppose it was microsofts way of combining Me and 2k...Anyway read my post about it explains what I did to make it behave like 2k did...

    ------------------
    -Xero

    [This message has been edited by Xero (edited November 01, 2001).]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •